Skip to main content
← All vulnerabilities
CVE-2025-58121

Insufficient permission validation on multiple REST API endpoints

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.0p16
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Insufficient permission validation on multiple REST API endpoints in Checkmk 2.2.0, 2.3.0, and 2.4.0 before version 2.4.0p16 allows low-privileged users to perform unauthorized actions or obtain sensitive information

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Checkmk GmbH Checkmk

    From 2.4.0 · fixed in 2.4.0p16

References 1

checkmk.com