Skip to main content
← All vulnerabilities
CVE-2025-58064GHSA-X9GP-VJH6-3WV6

CKEditor is susceptible to Cross-Site Scripting (XSS) through its clipboard package

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 46.0.3, 45.2.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

CKEditor 5 is a modern JavaScript rich-text editor with an MVC architecture. ckeditor5 and ckeditor5-clipboard versions 46.0.0 through 46.0.2 and 44.2.0 through 45.2.1 contain a Cross-Site Scripting (XSS) vulnerability. Ability to exploit could be triggered by a specific user action (leading to unauthorized JavaScript code execution) if the attacker managed to insert a malicious content into the editor, which might happen with a very specific editor configuration. This vulnerability affects installations where the editor configuration meets one of the following criteria: the HTML embed plugin is enabled, or there is a custom plugin introducing an editable element where view RawElement is enabled. This issue is fixed in versions 45.2.2 and 46.0.3 of both ckeditor5 and ckeditor5-clipboard.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • ckeditor ckeditor5

    From 46.0.0 · fixed in 46.0.3; From 44.2.0 · fixed in 45.2.2

  • ckeditor5npm

    From 46.0.0 · fixed in 46.0.3

  • @ckeditor/ckeditor5-clipboardnpm

    From 44.2.0 · fixed in 45.2.2

  • ckeditor5npm

    From 44.2.0 · fixed in 45.2.2

  • @ckeditor/ckeditor5-clipboardnpm

    From 46.0.0 · fixed in 46.0.3

References 2

GitHub · ckeditor/ckeditor5