Skip to main content
← All vulnerabilities
CVE-2025-57760PYSEC-2025-243GHSA-4GV9-MP8M-592RPYSEC-2026-1526

Langflow Vulnerable to Privilege Escalation via CLI Superuser Creation

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.5.0, 0.5.1, 1.5.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

Langflow is a tool for building and deploying AI-powered agents and workflows. A privilege escalation vulnerability exists in Langflow containers where an authenticated user with RCE access can invoke the internal CLI command langflow superuser to create a new administrative user. This results in full superuser access, even if the user initially registered through the UI as a regular (non-admin) account. A patched version has not been made public at this time.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • langflow-ai langflow

    through 1.5.0

  • langflowPyPI

    fixed in 1.5.0

  • langflow-basePyPI

    fixed in 0.5.1

  • langflowPyPI

    fixed in 1.5.1

References 3

GitHub · langflow-ai/langflow