CVE-2025-57759GHSA-QQFQ-7CPP-HCQJ
Contao has improper privilege management for page and article fields
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 5.3.38, 5.6.1
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: partial
Summary
Contao is an Open Source CMS. In versions starting from 5.3.0 and prior to 5.3.38 and 5.6.1, under certain conditions, back end users may be able to edit fields of pages and articles without having the necessary permissions. This issue has been patched in versions 5.3.38 and 5.6.1. There are no workarounds.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: partial
- Record last updated
Affected versions
- contao contao
From 5.3.0 · fixed in 5.3.38; From 5.4.0-RC1 · fixed in 5.6.1
- contao/core-bundlePackagist
From 5.3.0 · fixed in 5.3.38
- contao/core-bundlePackagist
From 5.4.0-RC1 · fixed in 5.6.1
- contao/contaoPackagist
From 5.3.0 · fixed in 5.3.38
- contao/contaoPackagist
From 5.4.0-RC1 · fixed in 5.6.1