Skip to main content
← All vulnerabilities
CVE-2025-57738GHSA-825G-MM5V-GGQ4

Apache Syncope: Remote Code Execution by delegated administrators

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.0.14, 4.0.2
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Apache Syncope offers the ability to extend / customize the base behavior on every deployment by allowing to provide custom implementations of a few Java interfaces; such implementations can be provided either as Java or Groovy classes, with the latter being particularly attractive as the machinery is set for runtime reload. Such a feature has been available for a while, but recently it was discovered that a malicious administrator can inject Groovy code that can be executed remotely by a running Apache Syncope Core instance. Users are recommended to upgrade to version 3.0.14 / 4.0.2, which fix this issue by forcing the Groovy code to run in a sandbox.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Syncope

    From 2.1 · through 2.1.14; From 3.0 · through 3.0.13; From 4.0 · through 4.0.1

  • org.apache.syncope.core:syncope-core-springMaven

    fixed in 3.0.14

  • org.apache.syncope.core:syncope-core-springMaven

    From 4.0.0-M0 · fixed in 4.0.2

References 1

lists.apache.org