Apache Tomcat: console manipulation via escape sequences in log messages
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- The rating the maker of the software gives it. Shown when it differs from the CVSS level.What do these mean? →
- Low (apache)
- Fix
- Fixed in 11.0.11, 10.1.45, 9.0.109
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Improper Neutralization of Escape, Meta, or Control Sequences vulnerability in Apache Tomcat. Tomcat did not escape ANSI escape sequences in log messages. If Tomcat was running in a console on a Windows operating system, and the console supported ANSI escape sequences, it was possible for an attacker to use a specially crafted URL to inject ANSI escape sequences to manipulate the console and the clipboard and attempt to trick an administrator into running an attacker controlled command. While no attack vector was found, it may have been possible to mount this attack on other operating systems. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.10, from 10.1.0-M1 through 10.1.44, from 9.0.40 through 9.0.108. The following versions were EOL at the time the CVE was created but are known to be affected: 8.5.60 though 8.5.100. Other, older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.11 or later, 10.1.45 or later or 9.0.109 or later, which fix the issue.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
- EPSS reached 10%
FIRST estimates at least a 10% chance of exploitation in the next 30 days
Affected versions
- Apache Software Foundation Apache Tomcat
From 11.0.0-M1 · through 11.0.10; From 10.1.0-M1 · through 10.1.44; From 9.0.40 · through 9.0.108; From 8.5.60 · through 8.5.100
- org.apache.tomcat:tomcatMaven
From 11.0.0-M1 · fixed in 11.0.11
- org.apache.tomcat:tomcatMaven
From 10.1.0-M1 · fixed in 10.1.45
- org.apache.tomcat:tomcatMaven
From 9.0.40 · fixed in 9.0.109
- org.apache.tomcat:tomcatMaven
From 8.5.60 · through 8.5.100
- org.apache.tomcat.embed:tomcat-embed-coreMaven
From 11.0.0-M1 · fixed in 11.0.11
- org.apache.tomcat.embed:tomcat-embed-coreMaven
From 10.1.0-M1 · fixed in 10.1.45
- org.apache.tomcat.embed:tomcat-embed-coreMaven
From 9.0.40 · fixed in 9.0.109
- org.apache.tomcat.embed:tomcat-embed-coreMaven
From 8.5.60 · through 8.5.100
- org.apache.tomcat:tomcat-catalinaMaven
From 11.0.0-M1 · fixed in 11.0.11
- org.apache.tomcat:tomcat-catalinaMaven
From 10.1.0-M1 · fixed in 10.1.45
- org.apache.tomcat:tomcat-catalinaMaven
From 9.0.40 · fixed in 9.0.109
- org.apache.tomcat:tomcat-catalinaMaven
From 8.5.60 · through 8.5.100