Skip to main content
← All vulnerabilities
CVE-2025-54869GHSA-JXHH-4648-VPP3

FPDI is Vulnerable to Memory Exhaustion (OOM) through its PDF Parser

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.6.3, 2.6.4
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

FPDI is a collection of PHP classes that facilitate reading pages from existing PDF documents and using them as templates in FPDF. In versions 2.6.2 and below, any application that uses FPDI to process user-supplied PDF files is at risk, causing a Denial of Service (DoS) vulnerability. An attacker can upload a small, malicious PDF file that will cause the server-side script to crash due to memory exhaustion. Repeated attacks can lead to sustained service unavailability. This issue is fixed in version 2.6.3.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Setasign FPDI

    fixed in 2.6.3

  • setasign/fpdiPackagist

    fixed in 2.6.4

References 2

GitHub · Setasign/FPDI