Skip to main content
← All vulnerabilities
CVE-2025-54286GO-2025-4003GHSA-P8HW-RFJG-689H

CSRF Vulnerability When Using Client Certificate Authentication with the LXD-UI

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.0.5, 5.21.4, 6.5, 0.0.0-20250827065555-0494f5d47e41
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Cross-Site Request Forgery (CSRF) in LXD-UI in Canonical LXD versions >= 5.0 on Linux allows an attacker to create and start container instances without user consent via crafted HTML form submissions exploiting client certificate authentication.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Canonical LXD

    From 5.0 · fixed in 5.0.5; From 5.21 · fixed in 5.21.4; From 6.0 · fixed in 6.5

  • github.com/canonical/lxdGo

    All versions

  • github.com/canonical/lxdGo

    From 5.0 · fixed in 5.0.5

  • github.com/canonical/lxdGo

    From 5.1 · fixed in 5.21.4

  • github.com/canonical/lxdGo

    From 6.0 · fixed in 6.5

  • github.com/canonical/lxdGo

    From 0.0.0-20220401034332-1e1349e3cbf3 · fixed in 0.0.0-20250827065555-0494f5d47e41

References 1

GitHub · canonical/lxd