Skip to main content
← All vulnerabilities
CVE-2025-54266GHSA-PCRX-R49H-X2W5

Adobe Commerce | Cross-site Scripting (Stored XSS) (CWE-79)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.9-alpha3, 2.4.8-p3, 2.4.7-p8, 2.4.6-p13
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Adobe Commerce versions 2.4.9-alpha2, 2.4.8-p2, 2.4.7-p7, 2.4.6-p12, 2.4.5-p14, 2.4.4-p15 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by a high-privileged attacker to inject malicious scripts into vulnerable form fields. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field. Exploitation of this issue requires user interaction in that a victim must browse to the page containing the vulnerable field. Scope is changed.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    Version range not reported

  • magento/project-community-editionPackagist

    through 2.0.2

  • magento/community-editionPackagist

    From 2.4.9-alpha1 · fixed in 2.4.9-alpha3

  • magento/community-editionPackagist

    From 2.4.8-beta1 · fixed in 2.4.8-p3

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7-p8

  • magento/community-editionPackagist

    fixed in 2.4.6-p13

  • magento/community-editionPackagist

    2.4.8

  • magento/community-editionPackagist

    2.4.7

  • magento/community-editionPackagist

    2.4.6

References 1

helpx.adobe.com