Skip to main content
← All vulnerabilities
CVE-2025-54057GHSA-V6X2-4Q87-RF82

Apache SkyWalking: Stored XSS vulnerability

Published
Last modified
published
Not listed in CISA KEV
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Apache SkyWalking. This issue affects Apache SkyWalking: <= 10.2.0. Users are recommended to upgrade to version 10.3.0, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache SkyWalking

    through 10.2.0

  • org.apache.skywalking:apm-webappMaven

    through 10.1.0

References 1

lists.apache.org